{"action":"Upgrade knot-resolver to 5.0.1-1 or later.","affected":[{"fixed":"5.0.1-1","introduced":"0"}],"component":"knot-resolver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.0.1-1"],"id":"tcs_01M5NDMK5MQ7S9MTVHRP61JZP2","modified_at":"2026-09-21T07:00:35.180292578Z","published_at":"2019-07-16T18:15:12.087Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-10190","https://security-tracker.debian.org/tracker/CVE-2019-10190"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-10190","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-10190"}],"summary":"A vulnerability was discovered in DNS resolver component of knot resolver through version 3.2.0 before 4.1.0 which allows remote attackers to bypass DNSSEC validation for non-existence answer. NXDOMAI"}