{"action":"Upgrade knot-resolver to 5.0.1-1 or later.","affected":[{"fixed":"5.0.1-1","introduced":"0"}],"component":"knot-resolver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.0.1-1"],"id":"tcs_01M5NDMKRBQ7BD2SEY4WH71S38","modified_at":"2026-09-21T07:00:49.922060005Z","published_at":"2019-07-16T18:15:12.180Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-10191","https://security-tracker.debian.org/tracker/CVE-2019-10191"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-10191#Debian:14/knot-resolver","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-10191"}],"summary":"A vulnerability was discovered in DNS resolver of knot resolver before version 4.1.0 which allows remote attackers to downgrade DNSSEC-secure domains to DNSSEC-insecure state, opening possibility of d"}