{"action":"Upgrade robocode to 1.9.3.3-2 or later.","affected":[{"fixed":"1.9.3.3-2","introduced":"0"}],"component":"robocode","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.9.3.3-2"],"id":"tcs_01M5NDMZ2FYSMRXP5KD2QE64BS","modified_at":"2026-09-21T07:00:51.861400032Z","published_at":"2019-03-30T13:29:00.657Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-10648","https://security-tracker.debian.org/tracker/CVE-2019-10648"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-10648","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-10648"}],"summary":"Robocode through 1.9.3.5 allows remote attackers to cause external service interaction (DNS), as demonstrated by a query for a unique subdomain name within an attacker-controlled DNS zone, because of"}