{"action":"Upgrade node-yarnpkg to 1.21.1-1 or later.","affected":[{"fixed":"1.21.1-1","introduced":"0"}],"component":"node-yarnpkg","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.21.1-1"],"id":"tcs_01M5NDN4K7QGE63FJMET3YCT8S","modified_at":"2026-09-21T07:00:36.298540924Z","published_at":"2019-12-16T20:15:14.477Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-10773","https://security-tracker.debian.org/tracker/CVE-2019-10773"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-10773","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-10773"}],"summary":"In Yarn before 1.21.1, the package install functionality can be abused to generate arbitrary symlinks on the host filesystem by using specially crafted \"bin\" keys. Existing files could be overwritten"}