{"action":"Upgrade checkstyle to 8.29-1 or later.","affected":[{"fixed":"8.29-1","introduced":"0"}],"component":"checkstyle","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["8.29-1"],"id":"tcs_01M5NDN59GMB8JKX55FW60NRHX","modified_at":"2026-09-21T07:00:36.249758555Z","published_at":"2020-01-30T23:15:10.093Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-10782","https://security-tracker.debian.org/tracker/CVE-2019-10782"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-10782","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-10782"}],"summary":"All versions of com.puppycrawl.tools:checkstyle before 8.29 are vulnerable to XML External Entity (XXE) Injection due to an incomplete fix for CVE-2019-9658."}