{"action":"Upgrade dojo to 1.15.2+dfsg1-1 or later.","affected":[{"fixed":"1.15.2+dfsg1-1","introduced":"0"}],"component":"dojo","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.15.2+dfsg1-1"],"id":"tcs_01M5NDN5WP9K025B05K2184XWJ","modified_at":"2026-09-21T07:00:36.526336162Z","published_at":"2020-02-13T17:15:29.477Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-10785","https://security-tracker.debian.org/tracker/CVE-2019-10785"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-10785","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-10785"}],"summary":"dojox is vulnerable to Cross-site Scripting in all versions before version 1.16.1, 1.15.2, 1.14.5, 1.13.6, 1.12.7 and 1.11.9. This is due to dojox.xmpp.util.xmlEncode only encoding the first occurrenc"}