{"action":"Upgrade vim to 8.2.4969-r0 or later.","affected":[{"fixed":"8.2.4969-r0","introduced":"0"}],"component":"vim","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.20","exploited":false,"fixed_versions":["8.2.4969-r0"],"id":"tcs_01M5NDQEC888KQF8YS5V6PB8YV","modified_at":"2026-10-15T07:17:54.154722613Z","published_at":"2022-05-10T14:15:08.460Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-1621","https://security.alpinelinux.org/vuln/CVE-2022-1621"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-1621#Alpine:v3.20/vim","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-1621"}],"summary":"Heap buffer overflow in vim_strncpy find_word in GitHub repository vim/vim prior to 8.2.4919. This vulnerability is capable of crashing software, Bypass Protection Mechanism, Modify Memory, and possib"}