{"action":"Upgrade miniupnpd to 2.1-6 or later.","affected":[{"fixed":"2.1-6","introduced":"0"}],"component":"miniupnpd","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.1-6"],"id":"tcs_01M5NDQMQ2PBJ7J0VCWCGGGK6D","modified_at":"2026-09-21T07:01:45.485357614Z","published_at":"2019-05-15T23:29:00.510Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-12107","https://security-tracker.debian.org/tracker/CVE-2019-12107"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-12107","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-12107"}],"summary":"The upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote attacker to leak information from the heap due to improper validation of an snprintf return value."}