{"action":"Upgrade twisted to 18.9.0-7 or later.","affected":[{"fixed":"18.9.0-7","introduced":"0"}],"component":"twisted","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["18.9.0-7"],"id":"tcs_01M5NDR327XAHA14TA8DN2QZNG","modified_at":"2026-09-21T07:02:03.861511393Z","published_at":"2019-06-10T12:29:00.287Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-12387","https://security-tracker.debian.org/tracker/CVE-2019-12387"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-12387#Debian:14/twisted","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-12387"}],"summary":"In Twisted before 19.2.1, twisted.web did not validate or sanitize URIs or HTTP methods, allowing an attacker to inject invalid characters such as CRLF."}