{"action":"Upgrade squid to 4.8-1 or later.","affected":[{"fixed":"4.8-1","introduced":"0"}],"component":"squid","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["4.8-1"],"id":"tcs_01M5NDRF01KPWAEVN0GGSBJVCV","modified_at":"2026-09-21T07:01:49.115640859Z","published_at":"2019-07-11T19:15:13Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-12525","https://security-tracker.debian.org/tracker/CVE-2019-12525"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-12525#Debian:13/squid","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-12525"}],"summary":"An issue was discovered in Squid 3.3.9 through 3.5.28 and 4.x through 4.7. When Squid is configured to use Digest authentication, it parses the header Proxy-Authorization. It searches for certain toke"}