{"action":"Upgrade squid to 4.8-1 or later.","affected":[{"fixed":"4.8-1","introduced":"0"}],"component":"squid","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.8-1"],"id":"tcs_01M5NDRFHEKKY8AHQR9DN25PQA","modified_at":"2026-09-21T07:01:48.050108492Z","published_at":"2019-07-11T19:15:13.097Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-12527","https://security-tracker.debian.org/tracker/CVE-2019-12527"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-12527","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-12527"}],"summary":"An issue was discovered in Squid 4.0.23 through 4.7. When checking Basic Authentication with HttpHeader::getAuth, Squid uses a global buffer to store the decoded data. Squid does not check that the de"}