{"action":"Upgrade squid to 4.10-1 or later.","affected":[{"fixed":"4.10-1","introduced":"0"}],"component":"squid","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.10-1"],"id":"tcs_01M5NDRGDCHBJHWR502M3353MD","modified_at":"2026-09-21T07:01:48.413112136Z","published_at":"2020-02-04T21:15:10.807Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-12528","https://security-tracker.debian.org/tracker/CVE-2019-12528"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-12528#Debian:14/squid","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-12528"}],"summary":"An issue was discovered in Squid before 4.10. It allows a crafted FTP server to trigger disclosure of sensitive information from heap memory, such as information associated with other users' sessions"}