{"action":"Upgrade neovim to 0.3.4-3 or later.","affected":[{"fixed":"0.3.4-3","introduced":"0"}],"component":"neovim","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.3.4-3"],"id":"tcs_01M5NDRKPAGQBS2SHKJFTEJRJA","modified_at":"2026-09-21T07:01:50.644061318Z","published_at":"2019-06-05T14:29:11.387Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-12735","https://security-tracker.debian.org/tracker/CVE-2019-12735"],"severity":{"label":"high","score":8.6},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-12735#Debian:14/neovim","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-12735"}],"summary":"getchar.c in Vim before 8.1.1365 and Neovim before 0.3.6 allows remote attackers to execute arbitrary OS commands via the :source! command in a modeline, as demonstrated by execute in Vim, and assert_"}