{"action":"Upgrade vim to 2:8.1.0875-4 or later.","affected":[{"fixed":"2:8.1.0875-4","introduced":"0"}],"component":"vim","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2:8.1.0875-4"],"id":"tcs_01M5NDRKSG8YZB80TW0N0VMGD2","modified_at":"2026-09-21T07:01:50.644061318Z","published_at":"2019-06-05T14:29:11.387Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-12735","https://security-tracker.debian.org/tracker/CVE-2019-12735"],"severity":{"label":"high","score":8.6},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-12735#Debian:12/vim","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-12735"}],"summary":"getchar.c in Vim before 8.1.1365 and Neovim before 0.3.6 allows remote attackers to execute arbitrary OS commands via the :source! command in a modeline, as demonstrated by execute in Vim, and assert_"}