{"action":"Upgrade libqb to 1.0.4-1 or later.","affected":[{"fixed":"1.0.4-1","introduced":"0"}],"component":"libqb","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.0.4-1"],"id":"tcs_01M5NDRN7BZ1WHPQ51AV12P41T","modified_at":"2026-09-21T07:00:27.864139788Z","published_at":"2019-06-07T20:29:00.857Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-12779","https://security-tracker.debian.org/tracker/CVE-2019-12779"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-12779","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-12779"}],"summary":"libqb before 1.0.5 allows local users to overwrite arbitrary files via a symlink attack, because it uses predictable filenames (under /dev/shm and /tmp) without O_EXCL."}