{"action":"Upgrade swupdate to 2021.04-1 or later.","affected":[{"fixed":"2021.04-1","introduced":"0"}],"component":"swupdate","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2021.04-1"],"id":"tcs_01M5NDRWDP7ZF5992H92Y0R6QQ","modified_at":"2026-09-21T07:02:17.064653642Z","published_at":"2019-06-24T23:15:12.210Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-12951","https://security-tracker.debian.org/tracker/CVE-2019-12951"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-12951#Debian:14/swupdate","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-12951"}],"summary":"An issue was discovered in Mongoose before 6.15. The parse_mqtt() function in mg_mqtt.c has a critical heap-based buffer overflow."}