{"action":"Upgrade vim to 9.0.0050-r0 or later.","affected":[{"fixed":"9.0.0050-r0","introduced":"0"}],"component":"vim","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.21","exploited":false,"fixed_versions":["9.0.0050-r0"],"id":"tcs_01M5NDSRPC290Z9285Q9WVKC7J","modified_at":"2026-10-15T07:17:54.163390646Z","published_at":"2022-07-02T15:15:07.987Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-2284","https://security.alpinelinux.org/vuln/CVE-2022-2284"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-2284#Alpine:v3.21/vim","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-2284"}],"summary":"Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0."}