{"action":"Upgrade expat to 2.4.4-r0 or later.","affected":[{"fixed":"2.4.4-r0","introduced":"0"}],"component":"expat","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.18","exploited":false,"fixed_versions":["2.4.4-r0"],"id":"tcs_01M5NDV13AE8EBKJ5ZQ1SW2M67","modified_at":"2026-10-15T07:17:54.167521291Z","published_at":"2022-01-24T02:15:06.733Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-23852","https://security.alpinelinux.org/vuln/CVE-2022-23852"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-23852#Alpine:v3.18/expat","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-23852"}],"summary":"Expat (aka libexpat) before 2.4.4 has a signed integer overflow in XML_GetBuffer, for configurations with a nonzero XML_CONTEXT_BYTES."}