{"action":"Upgrade gdnsd to 3.5.0-1 or later.","affected":[{"fixed":"3.5.0-1","introduced":"0"}],"component":"gdnsd","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.5.0-1"],"id":"tcs_01M5NDVESAM06J8YKG8BTCF2GY","modified_at":"2026-09-21T07:00:38.404213688Z","published_at":"2019-07-18T17:15:12.083Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-13952","https://security-tracker.debian.org/tracker/CVE-2019-13952"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-13952","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-13952"}],"summary":"The set_ipv6() function in zscan_rfc1035.rl in gdnsd before 2.4.3 and 3.x before 3.2.1 has a stack-based buffer overflow via a long and malformed IPv6 address in zone data."}