{"action":"Upgrade wolfssl to 4.2.0+dfsg-1 or later.","affected":[{"fixed":"4.2.0+dfsg-1","introduced":"0"}],"component":"wolfssl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.2.0+dfsg-1"],"id":"tcs_01M5NDVT1S36Z8WKMM464S8WJP","modified_at":"2026-09-21T07:02:06.954657643Z","published_at":"2019-12-11T18:16:18.880Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-14317","https://security-tracker.debian.org/tracker/CVE-2019-14317"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-14317","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-14317"}],"summary":"wolfSSL and wolfCrypt 4.1.0 and earlier (formerly known as CyaSSL) generate biased DSA nonces. This allows a remote attacker to compute the long term private key from several hundred DSA signatures vi"}