{"action":"Upgrade expat to 2.2.10-r4 or later.","affected":[{"fixed":"2.2.10-r4","introduced":"0"}],"component":"expat","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.13","exploited":false,"fixed_versions":["2.2.10-r4"],"id":"tcs_01M5NDX4DYBWYMBZPZMRHATC5N","modified_at":"2026-10-15T07:17:54.173732449Z","published_at":"2022-02-16T01:15:07.607Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-25235","https://security.alpinelinux.org/vuln/CVE-2022-25235"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-25235#Alpine:v3.13/expat","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-25235"}],"summary":"xmltok_impl.c in Expat (aka libexpat) before 2.4.5 lacks certain validation of encoding, such as checks for whether a UTF-8 character is valid in a certain context."}