{"action":"Upgrade undertow to 2.0.30-1 or later.","affected":[{"fixed":"2.0.30-1","introduced":"0"}],"component":"undertow","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.0.30-1"],"id":"tcs_01M5NDX5EET2KMPAJSTGKNF2X9","modified_at":"2026-09-21T07:02:08.966143922Z","published_at":"2020-01-23T17:15:11.767Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-14888","https://security-tracker.debian.org/tracker/CVE-2019-14888"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-14888","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-14888"}],"summary":"A vulnerability was found in the Undertow HTTP server in versions before 2.0.28.SP1 when listening on HTTPS. An attacker can target the HTTPS port to carry out a Denial Of Service (DOS) to make the se"}