{"action":"Upgrade rust-libflate to 0.1.25-1 or later.","affected":[{"fixed":"0.1.25-1","introduced":"0"}],"component":"rust-libflate","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.1.25-1"],"id":"tcs_01M5NDXZASZKGG1PHDEPETBRK3","modified_at":"2026-09-21T07:02:44.914919845Z","published_at":"2019-08-26T15:15:12.063Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-15552","https://security-tracker.debian.org/tracker/CVE-2019-15552"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-15552#Debian:14/rust-libflate","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-15552"}],"summary":"An issue was discovered in the libflate crate before 0.1.25 for Rust. MultiDecoder::read has a use-after-free, leading to arbitrary code execution."}