{"action":"Upgrade expat to 2.2.7-2 or later.","affected":[{"fixed":"2.2.7-2","introduced":"0"}],"component":"expat","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.2.7-2"],"id":"tcs_01M5NDYHQ8FP33P2VJ0DZHHBE6","modified_at":"2026-10-15T07:47:38.820851837Z","published_at":"2019-09-04T06:15:10.877Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-15903","https://security-tracker.debian.org/tracker/CVE-2019-15903"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-15903#Debian:14/expat","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-15903"}],"summary":"In libexpat before 2.2.8, crafted XML input could fool the parser into changing from DTD parsing to document parsing too early; a consecutive call to XML_GetCurrentLineNumber (or XML_GetCurrentColumnN"}