{"action":"Upgrade jruby to 9.3.9.0+ds-1 or later.","affected":[{"fixed":"9.3.9.0+ds-1","introduced":"0"}],"component":"jruby","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["9.3.9.0+ds-1"],"id":"tcs_01M5NDYZHWWC5YJ9W8HN7WAFWC","modified_at":"2026-09-21T07:00:59.880205715Z","published_at":"2019-11-26T18:15:15.100Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-16201","https://security-tracker.debian.org/tracker/CVE-2019-16201"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-16201#Debian:13/jruby","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-16201"}],"summary":"WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBri"}