{"action":"Upgrade jruby to 9.3.9.0+ds-1 or later.","affected":[{"fixed":"9.3.9.0+ds-1","introduced":"0"}],"component":"jruby","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["9.3.9.0+ds-1"],"id":"tcs_01M5NDZ9HB7KSFXKYZTH381DB4","modified_at":"2026-09-21T07:01:00.330285874Z","published_at":"2019-11-26T18:15:15.303Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-16255","https://security-tracker.debian.org/tracker/CVE-2019-16255"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-16255","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-16255"}],"summary":"Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the \"command\" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. A"}