{"action":"Upgrade gradle to 4.4.1-18 or later.","affected":[{"fixed":"4.4.1-18","introduced":"0"}],"component":"gradle","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["4.4.1-18"],"id":"tcs_01M5NDZAZ52B8WZFF80R1RTJPE","modified_at":"2026-09-21T07:02:48.469887086Z","published_at":"2019-09-16T18:15:12.190Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-16370","https://security-tracker.debian.org/tracker/CVE-2019-16370"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-16370#Debian:13/gradle","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-16370"}],"summary":"The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related i"}