{"action":"Upgrade npm to 6.13.4+ds-2 or later.","affected":[{"fixed":"6.13.4+ds-2","introduced":"0"}],"component":"npm","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["6.13.4+ds-2"],"id":"tcs_01M5NDZN2JM5SM5VE9XY73PMN2","modified_at":"2026-09-21T07:02:45.367026381Z","published_at":"2019-12-13T01:15:11.007Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-16777","https://security-tracker.debian.org/tracker/CVE-2019-16777"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-16777#Debian:13/npm","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-16777"}],"summary":"Versions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For ex"}