{"action":"Upgrade waitress to 1.4.1-1 or later.","affected":[{"fixed":"1.4.1-1","introduced":"0"}],"component":"waitress","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.4.1-1"],"id":"tcs_01M5NDZQQES9M8D693MEC6VGZT","modified_at":"2026-09-21T07:02:28.166603886Z","published_at":"2020-01-22T19:15:11.140Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-16792","https://security-tracker.debian.org/tracker/CVE-2019-16792"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-16792","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-16792"}],"summary":"Waitress through version 1.3.1 allows request smuggling by sending the Content-Length header twice. Waitress would header fold a double Content-Length header and due to being unable to cast the now co"}