{"action":"Upgrade redmine to 4.0.4-1 or later.","affected":[{"fixed":"4.0.4-1","introduced":"0"}],"component":"redmine","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.0.4-1"],"id":"tcs_01M5NE0KC9CAA4TVZT03VA6VPQ","modified_at":"2026-09-21T07:02:29.343521443Z","published_at":"2019-10-10T02:05:46.897Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-17427","https://security-tracker.debian.org/tracker/CVE-2019-17427"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-17427","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-17427"}],"summary":"In Redmine before 3.4.11 and 4.0.x before 4.0.4, persistent XSS exists due to textile formatting errors."}