{"action":"Upgrade libssh2 to 1.9.0-1 or later.","affected":[{"fixed":"1.9.0-1","introduced":"0"}],"component":"libssh2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.9.0-1"],"id":"tcs_01M5NE0MZ555C4BDM8AFP8PCHZ","modified_at":"2026-10-15T07:47:22.917532240Z","published_at":"2019-10-21T22:15:10.523Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-17498","https://security-tracker.debian.org/tracker/CVE-2019-17498"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-17498#Debian:13/libssh2","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-17498"}],"summary":"In libssh2 v1.9.0 and earlier versions, the SSH_MSG_DISCONNECT logic in packet.c has an integer overflow in a bounds check, enabling an attacker to specify an arbitrary (out-of-bounds) offset for a su"}