{"action":"Upgrade sudo to 1.8.31-1 or later.","affected":[{"fixed":"1.8.31-1","introduced":"0"}],"component":"sudo","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.8.31-1"],"id":"tcs_01M5NE2H60XARY11NWAYCB3K8H","modified_at":"2026-09-21T07:01:55.155354033Z","published_at":"2019-12-19T21:15:13.823Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-19234","https://security-tracker.debian.org/tracker/CVE-2019-19234"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-19234#Debian:13/sudo","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-19234"}],"summary":"In Sudo through 1.8.29, the fact that a user has been blocked (e.g., by using the ! character in the shadow file instead of a password hash) is not considered, allowing an attacker (who has access to"}