{"action":"Upgrade knot-resolver to 5.0.1-1 or later.","affected":[{"fixed":"5.0.1-1","introduced":"0"}],"component":"knot-resolver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.0.1-1"],"id":"tcs_01M5NE2QBJ7VS2D1S9VV7Q77JD","modified_at":"2026-09-21T07:00:40.700347631Z","published_at":"2019-12-16T16:15:11.660Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-19331","https://security-tracker.debian.org/tracker/CVE-2019-19331"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-19331","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-19331"}],"summary":"knot-resolver before version 4.3.0 is vulnerable to denial of service through high CPU utilization. DNS replies with very many resource records might be processed very inefficiently, in extreme cases"}