{"action":"Upgrade git to 1:2.24.0-2 or later.","affected":[{"fixed":"1:2.24.0-2","introduced":"0"}],"component":"git","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1:2.24.0-2"],"id":"tcs_01M5NE36ZW8GE40XSSR73RN6ZW","modified_at":"2026-09-21T07:01:56.718140143Z","published_at":"2019-12-11T00:15:13.260Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-19604","https://security-tracker.debian.org/tracker/CVE-2019-19604"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-19604#Debian:14/git","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-19604"}],"summary":"Arbitrary command execution is possible in Git before 2.20.2, 2.21.x before 2.21.1, 2.22.x before 2.22.2, 2.23.x before 2.23.1, and 2.24.x before 2.24.1 because a \"git submodule update\" operation can"}