{"action":"Upgrade nethack to 3.6.6-1 or later.","affected":[{"fixed":"3.6.6-1","introduced":"0"}],"component":"nethack","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.6.6-1"],"id":"tcs_01M5NE3KW26PD134Z03KMBZ1Z1","modified_at":"2026-09-21T07:03:09.836573258Z","published_at":"2019-12-19T18:15:12.647Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-19905","https://security-tracker.debian.org/tracker/CVE-2019-19905"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-19905","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-19905"}],"summary":"NetHack 3.6.x before 3.6.4 is prone to a buffer overflow vulnerability when reading very long lines from configuration files. This affects systems that have NetHack installed suid/sgid, and shared sys"}