{"action":"Upgrade pyyaml to 5.2-1 or later.","affected":[{"fixed":"5.2-1","introduced":"0"}],"component":"pyyaml","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.2-1"],"id":"tcs_01M5NE4WDBJNWAZJEWKNRETAD7","modified_at":"2026-09-21T07:00:41.552822334Z","published_at":"2020-02-19T04:15:10.803Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-20477","https://security-tracker.debian.org/tracker/CVE-2019-20477"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-20477","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-20477"}],"summary":"PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue ex"}