{"action":"Upgrade libvncserver to 0.9.12+dfsg-9 or later.","affected":[{"fixed":"0.9.12+dfsg-9","introduced":"0"}],"component":"libvncserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.9.12+dfsg-9"],"id":"tcs_01M5NE50SQD01259133KGFCNZM","modified_at":"2026-09-21T07:03:17.816428580Z","published_at":"2020-04-23T19:15:12.763Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-20788","https://security-tracker.debian.org/tracker/CVE-2019-20788"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-20788#Debian:13/libvncserver","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-20788"}],"summary":"libvncclient/cursor.c in LibVNCServer through 0.9.12 has a HandleCursorShape integer overflow and heap-based buffer overflow via a large height or width value. NOTE: this may overlap CVE-2019-15690."}