{"action":"Upgrade apache2 to 2.4.54-r0 or later.","affected":[{"fixed":"2.4.54-r0","introduced":"0"}],"component":"apache2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["2.4.54-r0"],"id":"tcs_01M5NE51MR1XJ2QSJSRP2JXGHX","modified_at":"2026-11-03T07:18:33.441705787Z","published_at":"2022-06-09T17:15:09.977Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-31813","https://security.alpinelinux.org/vuln/CVE-2022-31813"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-31813#Alpine:v3.23/apache2","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-31813"}],"summary":"Apache HTTP Server 2.4.53 and earlier may not send the X-Forwarded-* headers to the origin server based on client side Connection header hop-by-hop mechanism. This may be used to bypass IP based authe"}