{"action":"Upgrade libvncserver to 0.9.13+dfsg-1 or later.","affected":[{"fixed":"0.9.13+dfsg-1","introduced":"0"}],"component":"libvncserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.13+dfsg-1"],"id":"tcs_01M5NE54V7592XVXHE52FGFM2K","modified_at":"2026-09-21T07:02:32.671560737Z","published_at":"2020-06-17T16:15:11.463Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-20839","https://security-tracker.debian.org/tracker/CVE-2019-20839"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-20839","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-20839"}],"summary":"libvncclient/sockets.c in LibVNCServer before 0.9.13 has a buffer overflow via a long socket filename."}