{"action":"Upgrade modsecurity to 3.0.4-1 or later.","affected":[{"fixed":"3.0.4-1","introduced":"0"}],"component":"modsecurity","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.0.4-1"],"id":"tcs_01M5NE5H7DE83HF5SK2Q592BHD","modified_at":"2026-09-21T07:00:11.425183876Z","published_at":"2021-05-06T17:15:07.870Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-25043","https://security-tracker.debian.org/tracker/CVE-2019-25043"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-25043","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-25043"}],"summary":"ModSecurity 3.x before 3.0.4 mishandles key-value pair parsing, as demonstrated by a \"string index out of range\" error and worker-process crash for a \"Cookie: =abc\" header."}