{"action":"Upgrade qemu to 1:3.1+dfsg-5 or later.","affected":[{"fixed":"1:3.1+dfsg-5","introduced":"0"}],"component":"qemu","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1:3.1+dfsg-5"],"id":"tcs_01M5NE5ZS8570VPEYWGVM5N76S","modified_at":"2026-09-21T07:01:24.043236063Z","published_at":"2019-02-19T14:29:00.193Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-3812","https://security-tracker.debian.org/tracker/CVE-2019-3812"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-3812#Debian:14/qemu","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-3812"}],"summary":"QEMU, through version 2.10 and through version 3.1.0, is vulnerable to an out-of-bounds read of up to 128 bytes in the hw/i2c/i2c-ddc.c:i2c_ddc() function. A local attacker with permission to execute"}