{"action":"Upgrade pdns to 4.1.6-2 or later.","affected":[{"fixed":"4.1.6-2","introduced":"0"}],"component":"pdns","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.1.6-2"],"id":"tcs_01M5NE6CRCTTXT6VB3QXEHBYH4","modified_at":"2026-09-21T07:03:18.531848318Z","published_at":"2019-03-21T21:29:00.700Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-3871","https://security-tracker.debian.org/tracker/CVE-2019-3871"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-3871","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-3871"}],"summary":"A vulnerability was found in PowerDNS Authoritative Server before 4.0.7 and before 4.1.7. An insufficient validation of data coming from the user when building a HTTP request from a DNS query in the H"}