{"action":"Upgrade undertow to 2.0.23-1 or later.","affected":[{"fixed":"2.0.23-1","introduced":"0"}],"component":"undertow","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.0.23-1"],"id":"tcs_01M5NE6FX4Y7ABNE6403QY0G7Y","modified_at":"2026-09-21T07:01:03.107223144Z","published_at":"2019-06-12T14:29:04.790Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-3888","https://security-tracker.debian.org/tracker/CVE-2019-3888"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-3888","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-3888"}],"summary":"A vulnerability was found in Undertow web server before 2.0.21. An information exposure of plain text credentials through log files because Connectors.executeRootHandler:402 logs the HttpServerExchang"}