{"action":"Upgrade ruby-devise to 4.5.0-3 or later.","affected":[{"fixed":"4.5.0-3","introduced":"0"}],"component":"ruby-devise","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.5.0-3"],"id":"tcs_01M5NE6XG7ZM5H3FV14DNKJ1SG","modified_at":"2026-09-21T07:03:19.951601634Z","published_at":"2019-04-03T15:29:01.663Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-5421","https://security-tracker.debian.org/tracker/CVE-2019-5421"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-5421","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-5421"}],"summary":"Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts"}