{"action":"Upgrade c3p0 to 0.9.1.2-10.1 or later.","affected":[{"fixed":"0.9.1.2-10.1","introduced":"0"}],"component":"c3p0","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.9.1.2-10.1"],"id":"tcs_01M5NE6YA1J4NGDWQJGZ17RFT2","modified_at":"2026-09-21T07:03:19.377264812Z","published_at":"2019-04-22T21:29:00.523Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-5427","https://security-tracker.debian.org/tracker/CVE-2019-5427"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-5427#Debian:14/c3p0","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-5427"}],"summary":"c3p0 version < 0.9.5.4 may be exploited by a billion laughs attack when loading XML configuration due to missing protections against recursive entity expansion when loading configuration."}