{"action":"Upgrade vim to 8.2.4836-r1 or later.","affected":[{"fixed":"8.2.4836-r1","introduced":"0"}],"component":"vim","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.15","exploited":false,"fixed_versions":["8.2.4836-r1"],"id":"tcs_01M5NE7QP43CBGRMAXA59EN9N2","modified_at":"2026-10-15T07:17:54.231504221Z","published_at":"2022-12-02T19:15:11.010Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-3520","https://security.alpinelinux.org/vuln/CVE-2022-3520"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-3520","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-3520"}],"summary":"Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0765."}