{"action":"Upgrade squid to 5.2-r1 or later.","affected":[{"fixed":"5.2-r1","introduced":"2.5"}],"component":"squid","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.15","exploited":false,"fixed_versions":["5.2-r1"],"id":"tcs_01M5NEAKHDACR9P0M3H3ZQH9MF","modified_at":"2026-10-15T07:17:54.250430424Z","published_at":"2022-12-25T19:15:10.820Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-41318","https://security.alpinelinux.org/vuln/CVE-2022-41318"],"severity":{"label":"high","score":8.6},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-41318","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-41318"}],"summary":"A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended me"}