{"action":"Upgrade vim to 9.0.0999-r0 or later.","affected":[{"fixed":"9.0.0999-r0","introduced":"0"}],"component":"vim","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.21","exploited":false,"fixed_versions":["9.0.0999-r0"],"id":"tcs_01M5NEAPCZ92CJ88GP33F5Q188","modified_at":"2026-10-15T07:17:54.251373371Z","published_at":"2022-11-25T14:15:10.737Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-4141","https://security.alpinelinux.org/vuln/CVE-2022-4141"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-4141#Alpine:v3.21/vim","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-4141"}],"summary":"Heap based buffer overflow in vim/vim 9.0.0946 and below by allowing an attacker to CTRL-W gf in the expression used in the RHS of the substitute command."}