{"action":"Upgrade imagemagick to 8:6.9.10.23+dfsg-2.1 or later.","affected":[{"fixed":"8:6.9.10.23+dfsg-2.1","introduced":"0"}],"component":"imagemagick","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["8:6.9.10.23+dfsg-2.1"],"id":"tcs_01M5NEE1VVS8S7BKJR5F3EY3ZX","modified_at":"2026-09-21T07:03:26.634747260Z","published_at":"2019-03-24T00:29:00.213Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2019-9956","https://security-tracker.debian.org/tracker/CVE-2019-9956"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2019-9956#Debian:13/imagemagick","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2019-9956"}],"summary":"In ImageMagick 7.0.8-35 Q16, there is a stack-based buffer overflow in the function PopHexPixel of coders/ps.c, which allows an attacker to cause a denial of service or code execution via a crafted im"}