{"action":"Upgrade undertow to 2.2.0-1 or later.","affected":[{"fixed":"2.2.0-1","introduced":"0"}],"component":"undertow","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.2.0-1"],"id":"tcs_01M5NEEXK2136D9F78GK69H002","modified_at":"2026-10-26T12:01:11.801878168Z","published_at":"2020-09-23T13:15:15.157Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2020-10687","https://security-tracker.debian.org/tracker/CVE-2020-10687"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2020-10687","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2020-10687"}],"summary":"A flaw was discovered in all versions of Undertow before Undertow 2.2.0.Final, where HTTP request smuggling related to CVE-2017-2666 is possible against HTTP/1.x and HTTP/2 due to permitting invalid c"}